Re: [PATCH v3 4/4] dt-bindings: power: supply: max17042: Allow monitored-battery
From: Krzysztof Kozlowski
Date: Wed Jul 22 2026 - 04:19:49 EST
On Tue, Jul 21, 2026 at 02:57:36PM -0400, Vincent Cloutier wrote:
> From: Vincent Cloutier <vincent@xxxxxxxxxxx>
>
> The MAX17042 family binding references the generic power-supply schema,
> but additionalProperties only recognizes properties declared directly by
> this schema.
>
> Use unevaluatedProperties so properties inherited from power-supply.yaml,
> including monitored-battery, are allowed while unknown properties remain
> rejected.
>
> Assisted-by: OpenCode:gpt-5.6-sol
And the tool did not suggest to remove redundant properties?
> Signed-off-by: Vincent Cloutier <vincent@xxxxxxxxxxx>
> ---
> .../devicetree/bindings/power/supply/maxim,max17042.yaml | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/Documentation/devicetree/bindings/power/supply/maxim,max17042.yaml b/Documentation/devicetree/bindings/power/supply/maxim,max17042.yaml
> index 242b33f2bcba..395253ca7835 100644
> --- a/Documentation/devicetree/bindings/power/supply/maxim,max17042.yaml
> +++ b/Documentation/devicetree/bindings/power/supply/maxim,max17042.yaml
> @@ -73,7 +73,7 @@ required:
> - compatible
> - reg
You need to remove the power-supplies now.
Best regards,
Krzysztof