Re: [PATCH] iio: adc: at91_adc: use const char * for DT string property
From: David Lechner
Date: Wed Jul 22 2026 - 15:47:19 EST
On 7/22/26 2:39 PM, Amin GATTOUT wrote:
> Declare the local variable as const char * and remove the unnecessary cast
> when passing it to of_property_read_string().
>
> Signed-off-by: Amin GATTOUT <amin.gattout@xxxxxxxxx>
> ---
> drivers/iio/adc/at91_adc.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/iio/adc/at91_adc.c b/drivers/iio/adc/at91_adc.c
> index f610ad729bf3..0ac74ad92fca 100644
> --- a/drivers/iio/adc/at91_adc.c
> +++ b/drivers/iio/adc/at91_adc.c
> @@ -988,7 +988,7 @@ static int at91_adc_probe(struct platform_device *pdev)
> struct iio_dev *idev;
> struct at91_adc_state *st;
> u32 reg, prop;
> - char *s;
> + const char *s;
>
> idev = devm_iio_device_alloc(&pdev->dev, sizeof(struct at91_adc_state));
> if (!idev)
> @@ -1023,7 +1023,7 @@ static int at91_adc_probe(struct platform_device *pdev)
>
> st->res = st->caps->high_res_bits;
> if (st->caps->low_res_bits &&
> - !of_property_read_string(node, "atmel,adc-use-res", (const char **)&s)
> + !of_property_read_string(node, "atmel,adc-use-res", &s)
> && !strcmp(s, "lowres"))
> st->res = st->caps->low_res_bits;
>
>
> ---
> base-commit: 248951ddc14de84de3910f9b13f51491a8cd91df
> change-id: 20260722-master-23179d7c00c4
>
> Best regards,
Makes sense.
Reviewed-by: David Lechner <dlechner@xxxxxxxxxxxx>
Although perhaps could be simplified instead by using
of_property_match_string().