Re: [RFC PATCH v2 1/2] kho: Introduce a helper to init unsplit pages
From: Pranjal Shrivastava
Date: Wed Jul 22 2026 - 17:18:49 EST
On Mon, Jul 20, 2026 at 07:57:15PM +0300, Mike Rapoport wrote:
> > The current KHO restoration logic assumes all multi-page blocks are
> > split into independent 4KB pages. Break out a helper to prepare for
> > supporting high-order non-compound pages.
> >
> > Extract kho_init_unsplit_pages() to handle the refcount pattern
> > where only the head page is refcounted. Use the helper for folio
> > restoration that requires a similar refcount logic.
> >
> > Signed-off-by: Pranjal Shrivastava <praan@xxxxxxxxxx>
> >
> > diff --git a/kernel/liveupdate/kexec_handover.c b/kernel/liveupdate/kexec_handover.c
> > index 4834a809985ab..07f6f453cd69d 100644
> > --- a/kernel/liveupdate/kexec_handover.c
> > +++ b/kernel/liveupdate/kexec_handover.c
> > @@ -357,6 +357,24 @@ int kho_radix_walk_tree(struct kho_radix_tree *tree,
> > }
> > EXPORT_SYMBOL_GPL(kho_radix_walk_tree);
> >
> > +/* For physically contiguous pages. */
> > +static void kho_init_unsplit_pages(struct page *page, unsigned int order)
> > +{
>
> Can't say I like "unsplit". How about kho_init_high_order_page?
>
> And whatever name we pick here, it's surely must end with "page" rather
> than "pages".
>
Ack. I'll rename this to kho_init_high_order_page().
Thanks,
Praan