Re: [PATCH net-next 1/7] clk: Add devm_clk_bulk_get_enable()

From: Brian Masney

Date: Thu Jul 23 2026 - 11:04:38 EST


On Thu, Jul 23, 2026 at 06:08:32PM +0530, Suraj Gupta wrote:
> devm_clk_bulk_get_optional_enable() gets, prepares and enables a set of
> clocks with device-managed cleanup, but treats every clock as optional:
> a missing clock is silently returned as NULL instead of failing.
>
> Consumers that need a fixed set of mandatory clocks enabled for the
> lifetime of the device currently have to open-code devm_clk_bulk_get()
> followed by clk_bulk_prepare_enable(), which loses the managed disable on
> unbind, or fall back to per-clock devm_clk_get_enabled() calls.
>
> Add devm_clk_bulk_get_enable() as the non-optional counterpart. The
> underlying __devm_clk_bulk_get_enable() helper already supports the
> required (optional = false) path, so only export a thin wrapper for it.
>
> Signed-off-by: Suraj Gupta <suraj.gupta2@xxxxxxx>

Reviewed-by: Brian Masney <bmasney@xxxxxxxxxx>