Re: [PATCH] init/Kconfig: Move NUMA_BALANCING_DEFAULT_ENABLED next to NUMA_BALANCING

From: Julian Braha

Date: Thu Jul 23 2026 - 18:49:59 EST


Hi Bing,

On 7/23/26 06:50, Bing Huang wrote:
> The NUMA_BALANCING_DEFAULT_ENABLED config option is semantically
> related to NUMA_BALANCING. Move it directly after its parent option
> so they are grouped together, improving readability.
>
> No functional change.

Actually there is actually a minor functional difference to the Kconfig
frontend (e.g menuconfig): the prompt for this option will now be
indented below that of NUMA_BALANCING, rendered as part of its submenu.
(This is a good thing...)

Reviewed-by: Julian Braha <julianbraha@xxxxxxxxx>