Re: [PATCH v4 7/9] PCI: Make pci_match_one_device() match on ID instead of device

From: Danilo Krummrich

Date: Sat Jul 25 2026 - 11:41:19 EST


On Sat Jul 25, 2026 at 2:17 PM CEST, Gary Guo wrote:
> On Fri Jul 24, 2026 at 11:29 PM BST, Bjorn Helgaas wrote:
>> On Thu, Jul 23, 2026 at 11:00:46PM +0100, Gary Guo wrote:
>>> PCI dynamic ID needs to match IDs against a new ID to see if it already
>>> exists. Existing APIs can only match IDs against devices, causing the
>>> dynamic ID insertion code to create a temporary device only for matching
>>> purpose. Rename pci_match_one_device() to pci_match_one_id() so it can be
>>> used for this purpose instead; add a pci_id_from_device() helper to make it
>>> easy to convert users.
>>
>> s/causing the ... code to create/so the ... code creates/
>> s/purpose/purposes/
>>
>>> Similarly, convert pci_match_id() to do_pci_match_id(). But keep the
>>> existing API because there are many users.
>>>
>>> Reviewed-by: Danilo Krummrich <dakr@xxxxxxxxxx>
>>> Signed-off-by: Gary Guo <gary@xxxxxxxxxxx>
>>
>> Reviewed-by: Bjorn Helgaas <bhelgaas@xxxxxxxxxx>
>> Acked-by: Bjorn Helgaas <bhelgaas@xxxxxxxxxx>
>>
>> What's the merge strategy? If these all need to be merged together,
>> feel free to include the PCI patches whereever you merge the series.
>
> I think the series should be merged together, as I consider the driver changes
> included in this series being "fixing the users".
>
> The series should probably be taken via the PCI tree. I suppose one can also
> argue that the lifetime issue with device IDs isn't unique to PCI bus so this
> can also be considered driver-core material, but given that Greg has already
> taken the USB fixes via the USB tree the only unfixed bus left is PCI.
>
> So unless Danilo thinks otherwise I'd suggest the series be taken as a whole via
> PCI.

I'm happy to take it through driver-core if it helps, but the PCI tree seems to
be the natural fit. :)