[PATCH 5/9] ACPI: amba: drop unused assignment of acpi_device_id::driver_data

From: Pawel Zalewski (The Capable Hub)

Date: Mon Jul 27 2026 - 08:12:30 EST


This module sets the acpi_device_id::driver_data to 0 but
the field is not actually used within the module, we can
just drop it from the table.

While we are at it - used a named initializer for the
acpi_device_id::id field to increase readability and
drop explicitly setting the list terminator fields.

Signed-off-by: Pawel Zalewski (The Capable Hub) <pzalewski@xxxxxxxxxxxxxxxxxxxx>
---
drivers/acpi/arm64/amba.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/drivers/acpi/arm64/amba.c b/drivers/acpi/arm64/amba.c
index 1350083bce5f..e32b37a2126d 100644
--- a/drivers/acpi/arm64/amba.c
+++ b/drivers/acpi/arm64/amba.c
@@ -20,9 +20,9 @@
#include "init.h"

static const struct acpi_device_id amba_id_list[] = {
- {"ARMH0061", 0}, /* PL061 GPIO Device */
- {"ARMH0330", 0}, /* ARM DMA Controller DMA-330 */
- {"", 0},
+ { .id = "ARMH0061" }, /* PL061 GPIO Device */
+ { .id = "ARMH0330" }, /* ARM DMA Controller DMA-330 */
+ { }
};

static void amba_register_dummy_clk(void)

--
2.43.0