[PATCH 3/9] ACPI: pci: drop unused assignment of acpi_device_id::driver_data
From: Pawel Zalewski (The Capable Hub)
Date: Mon Jul 27 2026 - 08:12:50 EST
These modules set the acpi_device_id::driver_data to 0 but
the field is not actually used within the module, we can
just drop it from the table.
While we are at it - used a named initializer for the
acpi_device_id::id field to increase readability and
drop explicitly setting the list terminator fields.
Signed-off-by: Pawel Zalewski (The Capable Hub) <pzalewski@xxxxxxxxxxxxxxxxxxxx>
---
drivers/acpi/pci_link.c | 4 ++--
drivers/acpi/pci_root.c | 4 ++--
2 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/acpi/pci_link.c b/drivers/acpi/pci_link.c
index e6ed13aee48d..276dd36aaf23 100644
--- a/drivers/acpi/pci_link.c
+++ b/drivers/acpi/pci_link.c
@@ -36,8 +36,8 @@ static int acpi_pci_link_add(struct acpi_device *device,
static void acpi_pci_link_remove(struct acpi_device *device);
static const struct acpi_device_id link_device_ids[] = {
- {"PNP0C0F", 0},
- {"", 0},
+ { .id = "PNP0C0F" },
+ { }
};
static struct acpi_scan_handler pci_link_handler = {
diff --git a/drivers/acpi/pci_root.c b/drivers/acpi/pci_root.c
index 4c06c3ffd0cb..a129cb0c0a36 100644
--- a/drivers/acpi/pci_root.c
+++ b/drivers/acpi/pci_root.c
@@ -40,8 +40,8 @@ static int acpi_pci_root_scan_dependent(struct acpi_device *adev)
| OSC_PCI_MSI_SUPPORT)
static const struct acpi_device_id root_device_ids[] = {
- {"PNP0A03", 0},
- {"", 0},
+ { .id = "PNP0A03" },
+ { }
};
static struct acpi_scan_handler pci_root_handler = {
--
2.43.0