Re: [PATCH] staging: rtl8723bs: rename camelcase variable psurveyPara

From: Greg KH

Date: Mon Jul 27 2026 - 11:14:52 EST


On Mon, Jul 27, 2026 at 03:52:33PM +0200, Max Raulea wrote:
> Reported style issue by checkpatch in the rtl8723bs driver.
>
> changed the variable name to psurvey_para to adhere to Linux Kernel
> coding style.
>
> Signed-off-by: Max Raulea <max.raulea@xxxxxxxxx>
> ---
> drivers/staging/rtl8723bs/core/rtw_cmd.c | 18 +++++++++---------
> 1 file changed, 9 insertions(+), 9 deletions(-)
>
> diff --git a/drivers/staging/rtl8723bs/core/rtw_cmd.c b/drivers/staging/rtl8723bs/core/rtw_cmd.c
> index d8ad1c75195b..6304b218bc2d 100644
> --- a/drivers/staging/rtl8723bs/core/rtw_cmd.c
> +++ b/drivers/staging/rtl8723bs/core/rtw_cmd.c
> @@ -525,7 +525,7 @@ u8 rtw_sitesurvey_cmd(struct adapter *padapter, struct ndis_802_11_ssid *ssid,
> {
> u8 res = _FAIL;
> struct cmd_obj *ph2c;
> - struct sitesurvey_parm *psurveyPara;
> + struct sitesurvey_parm *psurvey_para;

Wait, sorry, no, this isn't right.

The leading "p" here is from the windows-style Hungarian notation,
trying to say this is a pointer. When really, we know this as the
compiler knows and enforces it, so there's no need to add it to the
name.

So this really should just be survey_para, right?

thanks,

greg k-h