[PATCH 0/2] Bluetooth: use named initializers for acpi_device_id

From: Pawel Zalewski (The Capable Hub)

Date: Mon Jul 27 2026 - 11:59:22 EST


This series is converting lists that contain the acpi_device_id
struct, which is defined in the include/linux/device-id/acpi.h
to makes use of named initializers (which they do not use currently).
This work is part of the on going effort in the kernel associated
with device-ids [1]

The plan is to convert acpi_device_id::driver_data to have an anonymous
union, similarly to what was introduced for PCI and I2C device ID tables.
The goal is to increase type-safety (as most of the existing casts are gone),
to improve readability and to make use intent a bit more clear:

```
union {
kernel_ulong_t driver_data;
const void *driver_data_ptr;
}
```

But for that to work all lists containing the structs need to use named
initializers first. I already have patches that implement this and touching
a lot of kernel subsystmes that use the acpi_device_id struct and that list
keeps on growing. Therefore, I have decided to split the series per every
subsystem into:
- pre-clean-ups that convert the lists to use named initializers
- actual implementations that make some of the modules use the new driver_data_ptr

That way the task can be fragmented into manageable and independent
chunks of work and makes this effort easier to review.

Tested builds on arm64 and x86-64 in Yocto on 7.2-rc5

[1] https://lore.kernel.org/all/cover.1780048925.git.u.kleine-koenig@xxxxxxxxxxxx/

Signed-off-by: Pawel Zalewski (The Capable Hub) <pzalewski@xxxxxxxxxxxxxxxxxxxx>
---
Pawel Zalewski (The Capable Hub) (2):
Bluetooth: use a named initializer for acpi_device_id
Bluetooth: hci_intel: drop unused assignment of acpi_device_id::driver_data

drivers/bluetooth/hci_bcm.c | 336 +++++++++++++++++++++---------------------
drivers/bluetooth/hci_h5.c | 6 +-
drivers/bluetooth/hci_intel.c | 4 +-
drivers/bluetooth/hci_qca.c | 12 +-
4 files changed, 179 insertions(+), 179 deletions(-)
---
base-commit: f5098b6bae761e346ebcd9da7f95622c04733cff
change-id: 20260727-acpi-bluetooth-c20f10b0e3f4

Best regards,
--
Pawel Zalewski (The Capable Hub) <pzalewski@xxxxxxxxxxxxxxxxxxxx>