Re: [PATCH 0/6] PCI/pwrctrl: tc9563: Several fixes and improvements

From: Bjorn Helgaas

Date: Mon Jul 27 2026 - 12:40:48 EST


On Sat, Jul 25, 2026 at 10:59:12AM +0200, Manivannan Sadhasivam via B4 Relay wrote:
> Hi,
>
> This series contains several fixes and improvements for the TC9563 Pwrctrl
> driver and the switch binding. Most of the fixes are related to ensuring
> correctness in parsing the DT properties for the switch ports and the
> integrated Endpoint.
>
> More details are in the individual patches.
>
> Testing
> =======
>
> This series was validated on the RB3Gen2 board.
>
> Signed-off-by: Manivannan Sadhasivam <manivannan.sadhasivam@xxxxxxxxxxxxxxxx>
> ---
> Manivannan Sadhasivam (6):
> dt-bindings: PCI: toshiba,tc9563: Restrict Tx Amplitude, DFE and N_FTS to USP, DSP1 and DSP2
> PCI/pwrctrl: tc9563: Fix parsing the integrated Ethernet MAC Endpoint node
> PCI/pwrctrl: tc9563: Power off only the external ports in tc9563_pwrctrl_disable_port()
> PCI/pwrctrl: tc9563: Skip Tx amplitude and DFE tuning for DSP3
> PCI/pwrctrl: tc9563: Rename DSP3 to VDSP
> PCI/pwrctrl: tc9563: Move Integrated MAC Endpoint out of 'tc9563_pwrctrl_ports' enum
>
> .../devicetree/bindings/pci/toshiba,tc9563.yaml | 21 +++-
> drivers/pci/pwrctrl/pci-pwrctrl-tc9563.c | 129 ++++++++++++++-------
> 2 files changed, 104 insertions(+), 46 deletions(-)

Added to pci/pwrctrl for v7.3, thanks!

Happy to revise if you respond to any of Alex's comments.