RE: [PATCH 3/6] clk: renesas: rzg2l: Add support for divider flags

From: Biju Das

Date: Mon Jul 27 2026 - 15:12:30 EST


Hi Geert,

Thanks for the feedback.

> -----Original Message-----
> From: Geert Uytterhoeven <geert@xxxxxxxxxxxxxx>
> Sent: 10 July 2026 16:41
> Subject: Re: [PATCH 3/6] clk: renesas: rzg2l: Add support for divider flags
>
> Hi Biju,
>
> On Fri, 19 Jun 2026 at 18:40, Biju <biju.das.au@xxxxxxxxx> wrote:
> > From: Biju Das <biju.das.jz@xxxxxxxxxxxxxx>
> >
> > Add support for passing divider flags apart from clock flags from soc
> > specific clock drivers.
> >
> > Signed-off-by: Biju Das <biju.das.jz@xxxxxxxxxxxxxx>
>
> Thanks for your patch!
>
> Reviewed-by: Geert Uytterhoeven <geert+renesas@xxxxxxxxx> One nit below...
>
> > --- a/drivers/clk/renesas/rzg2l-cpg.c
> > +++ b/drivers/clk/renesas/rzg2l-cpg.c
>
> > --- a/drivers/clk/renesas/rzg2l-cpg.h
> > +++ b/drivers/clk/renesas/rzg2l-cpg.h
> > @@ -112,6 +112,7 @@ struct cpg_core_clk {
> > notifier_fn_t notifier;
> > u32 flag;
>
> I think the time is ripe to rename this to core_flags. Or at least add the plural "s" ;-)

Agreed. Will rename this to core_flags.

Cheers,
Biju