Re: [PATCH -mm v2 1/1] sysctl: remove CONFIG_PROC_SYSCTL, it just mirrors CONFIG_SYSCTL

From: Nicolas Schier

Date: Mon Jul 27 2026 - 16:02:05 EST


On Mon, Jul 27, 2026 at 04:47:22PM +0200, Oleg Nesterov wrote:
> CONFIG_SYSCTL used to make sense as a separate hidden bool before commit
> 61a47c1ad3a4 ("sysctl: Remove the sysctl system call"); it was selected
> by both CONFIG_SYSCTL_SYSCALL and CONFIG_PROC_SYSCTL.
>
> Today CONFIG_PROC_SYSCTL is the only selector, so the two are always
> equal. Kill the hidden bool, rename the PROC_SYSCTL prompt to SYSCTL,
> and s/CONFIG_PROC_SYSCTL/CONFIG_SYSCTL/ tree-wide.
>
> Signed-off-by: Oleg Nesterov <oleg@xxxxxxxxxx>
> ---

[...]
> diff --git a/fs/proc/Kconfig b/fs/proc/Kconfig
> index 6ae966c561e7..24f5a36f45df 100644
> --- a/fs/proc/Kconfig
> +++ b/fs/proc/Kconfig
> @@ -80,10 +80,9 @@ config PROC_VMCORE_DEVICE_RAM
>
> Relevant architectures should select NEED_PROC_VMCORE_DEVICE_RAM.
>
> -config PROC_SYSCTL
> +config SYSCTL
> bool "Sysctl support (/proc/sys)" if EXPERT
> depends on PROC_FS
> - select SYSCTL
> default y
> help
> The sysctl interface provides a means of dynamically changing

Please be aware that renaming of Kconfig symbols may not be welcomed due
to unwanted effects for users and for bisecting, cp. last paragraph of

https://docs.kernel.org/process/handling-regressions.html#handling-regressions

and the original thread.

Personally, I do understand that it makes sense to clean this up, here.
As the default was and stays 'y' this should affect only "few" users,
but still I am feeling ambigious about it.

Sorry for missing to point to that at the RFC.

Kind regards,
Nicolas