Re: [PATCH] tcp: use kvmalloc_array() for BPF iterator batches
From: patchwork-bot+netdevbpf
Date: Mon Jul 27 2026 - 18:43:20 EST
Hello:
This patch was applied to bpf/bpf-next.git (master)
by Andrii Nakryiko <andrii@xxxxxxxxxx>:
On Thu, 16 Jul 2026 10:51:02 +0800 you wrote:
> Use kvmalloc_array() instead of open-coding the element-size
> multiplication when allocating the TCP BPF iterator batch.
>
> Signed-off-by: Weimin Xiong <xiongwm2026@xxxxxxx>
> ---
Here is the summary with links:
- tcp: use kvmalloc_array() for BPF iterator batches
https://git.kernel.org/bpf/bpf-next/c/fcf741584a56
You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html