Re: [PATCH net-next 3/9] netconsole: take over netpoll_setup() from netpoll

From: Gustavo Luiz Duarte

Date: Mon Jul 27 2026 - 19:40:37 EST


On Fri, Jul 24, 2026 at 4:05 PM Breno Leitao <leitao@xxxxxxxxxx> wrote:
>
> netpoll_setup() is only used by netconsole. All the other users use
> __netpoll_setup().
>
> Move netpoll_setup() to netconsole, and rename it to
> netcons_netpoll_setup().
>
> Pure code motion: the body is unchanged.
>
> Signed-off-by: Breno Leitao <leitao@xxxxxxxxxx>

Reviewed-by: Gustavo Luiz Duarte <gustavold@xxxxxxxxx>