Re: [PATCH RESEND v4 net-next 00/14] net: enetc: cleanups and improvements

From: patchwork-bot+netdevbpf

Date: Mon Jul 27 2026 - 19:45:51 EST


Hello:

This series was applied to netdev/net-next.git (main)
by Jakub Kicinski <kuba@xxxxxxxxxx>:

On Mon, 20 Jul 2026 09:43:02 +0800 you wrote:
> From: Wei Fang <wei.fang@xxxxxxx>
>
> The first group of patches (1, 2, 5-7) eliminates code duplication
> between the ENETC v1 and v4 drivers. Since both hardware generations
> share identical register layouts for MAC promiscuous mode, MAC hash
> filters, and VLAN promiscuous mode - differing only in register address
> offsets - common helper functions are extracted into enetc_pf_common.c
> and shared by both drivers.
>
> [...]

Here is the summary with links:
- [RESEND,v4,net-next,01/14] net: enetc: extract common helpers for MAC promiscuous mode setting
https://git.kernel.org/netdev/net-next/c/2557834ad0ff
- [RESEND,v4,net-next,02/14] net: enetc: extract common helpers for MAC hash filter configuration
https://git.kernel.org/netdev/net-next/c/0ce10770963e
- [RESEND,v4,net-next,03/14] net: enetc: convert ndo_set_rx_mode() to ndo_set_rx_mode_async()
https://git.kernel.org/netdev/net-next/c/debf0c7a34fa
- [RESEND,v4,net-next,04/14] net: enetc: improve MAFT entry management with bitmap tracking
https://git.kernel.org/netdev/net-next/c/6228fc9c2bbe
- [RESEND,v4,net-next,05/14] net: enetc: use PCI device name for debugfs directory
https://git.kernel.org/netdev/net-next/c/9db43e6f35db
- [RESEND,v4,net-next,06/14] net: enetc: simplify enetc4_set_port_speed()
https://git.kernel.org/netdev/net-next/c/c969fbc01d9e
- [RESEND,v4,net-next,07/14] net: enetc: differentiate phylink capabilities for pseudo-MAC and standalone MAC
https://git.kernel.org/netdev/net-next/c/7c9a6ae0edb2
- [RESEND,v4,net-next,08/14] net: enetc: remove invalid code from enetc4_pl_mac_link_up()
https://git.kernel.org/netdev/net-next/c/59bb3d62489c
- [RESEND,v4,net-next,09/14] net: enetc: open-code enetc4_set_default_si_vlan_promisc()
https://git.kernel.org/netdev/net-next/c/75e134261f61
- [RESEND,v4,net-next,10/14] net: enetc: refactor SI VLAN promiscuous mode configuration
https://git.kernel.org/netdev/net-next/c/f7c6dcd6444b
- [RESEND,v4,net-next,11/14] net: enetc: move enetc_set_si_vlan_promisc() to enetc_pf_common.c
https://git.kernel.org/netdev/net-next/c/ba07e3bef1b5
- [RESEND,v4,net-next,12/14] net: enetc: remove redundant num_vsi field from enetc_port_caps
https://git.kernel.org/netdev/net-next/c/75b136cf0f6f
- [RESEND,v4,net-next,13/14] net: enetc: use alloc_etherdev_mqs() to create netdev for VF driver
https://git.kernel.org/netdev/net-next/c/f0c1f31afd97
- [RESEND,v4,net-next,14/14] net: enetc: use kzalloc_flex() for enetc_psfp_gate allocation
https://git.kernel.org/netdev/net-next/c/18bf0ac84334

You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html