[PATCH 1/4] HID: intel-quicki2c: Use min() macro to simplify code
From: Chen Changcheng
Date: Mon Jul 27 2026 - 23:04:20 EST
Replace open-coded min() logic with the standard min() macro in
pci-quicki2c.c for setting i2c_max_frame_size and i2c_int_delay.
This improves code readability and is consistent with kernel coding
style.
Detected by Coccinelle:
./intel-thc-hid/intel-quicki2c/pci-quicki2c.c:213:22-24: WARNING opportunity for min()
./intel-thc-hid/intel-quicki2c/pci-quicki2c.c:218:22-24: WARNING opportunity for min()
Signed-off-by: Chen Changcheng <chenchangcheng@xxxxxxxxxx>
---
.../hid/intel-thc-hid/intel-quicki2c/pci-quicki2c.c | 11 ++---------
1 file changed, 2 insertions(+), 9 deletions(-)
diff --git a/drivers/hid/intel-thc-hid/intel-quicki2c/pci-quicki2c.c b/drivers/hid/intel-thc-hid/intel-quicki2c/pci-quicki2c.c
index 46d3e9a01999..bd099600bb9f 100644
--- a/drivers/hid/intel-thc-hid/intel-quicki2c/pci-quicki2c.c
+++ b/drivers/hid/intel-thc-hid/intel-quicki2c/pci-quicki2c.c
@@ -210,15 +210,8 @@ static int quicki2c_get_acpi_resources(struct quicki2c_device *qcdev)
qcdev->i2c_max_frame_size_enable = i2c_config.FSEN;
qcdev->i2c_int_delay_enable = i2c_config.INDE;
- if (i2c_config.FSVL <= qcdev->ddata->max_detect_size)
- qcdev->i2c_max_frame_size = i2c_config.FSVL;
- else
- qcdev->i2c_max_frame_size = qcdev->ddata->max_detect_size;
-
- if (i2c_config.INDV <= qcdev->ddata->max_interrupt_delay)
- qcdev->i2c_int_delay = i2c_config.INDV;
- else
- qcdev->i2c_int_delay = qcdev->ddata->max_interrupt_delay;
+ qcdev->i2c_max_frame_size = min(i2c_config.FSVL, qcdev->ddata->max_detect_size);
+ qcdev->i2c_int_delay = min(i2c_config.INDV, qcdev->ddata->max_interrupt_delay);
}
return 0;
--
2.25.1