Re: [PATCH v2 5/5] clk: scpi: use PLATFORM_DEVID_NONE for scpi-cpufreq

From: Sudeep Holla

Date: Tue Jul 28 2026 - 05:59:40 EST


On Tue, Jul 28, 2026 at 09:27:31AM +0800, Xixin Liu wrote:
> Replace the magic -1 passed to platform_device_register_simple() with
> PLATFORM_DEVID_NONE. The constant is defined as (-1) in
> platform_device.h; this is a readability cleanup only and does not
> change behavior.
>
> Fixes: 9490f01e2471 ("clk: scpi: add support for cpufreq virtual device")

This is not a fix, just a clean. I will drop this when applying.

--
Regards,
Sudeep