Re: [PATCH net] net: microchip: vcap api: Fix possible memory leak in vcap_decode_rule()
From: Abdun Nihaal
Date: Tue Jul 28 2026 - 07:42:55 EST
On Mon, Jul 27, 2026 at 10:26:34AM -0700, Joe Damato wrote:
> On Mon, Jul 27, 2026 at 06:27:55PM +0530, Abdun Nihaal wrote:
> Not sure what the style guidelines say, but the label err and the local
> variable err having the same name is a bit confusing.
>
> Maybe you could make the label "out_err" and update the gotos instead?
>
> Either way, the code looks right other than the style nit, so if you resend
> you can apply my tag:
>
> Reviewed-by: Joe Damato <joe@xxxxxxx>
Sure, I'll change the labels to out_err and send a v2.