Re: [PATCH 02/15] KVM: x86/pmu: Rename all_valid_pmc_idx to all_valid_pmc_mask
From: Sean Christopherson
Date: Tue Jul 28 2026 - 15:19:12 EST
On Tue, Jul 07, 2026, Zide Chen wrote:
> all_valid_pmc_idx is a bitmap of valid PMC indices, not an index
> itself; rename it to all_valid_pmc_mask to better reflect what it
> holds.
How about "pmc_exists"? All the other bitmaps start with pmc_ and describe when
the bit is set for the PMC.
DECLARE_BITMAP(pmc_in_use, X86_PMC_IDX_MAX);
DECLARE_BITMAP(pmc_counting_instructions, X86_PMC_IDX_MAX);
DECLARE_BITMAP(pmc_counting_branches, X86_PMC_IDX_MAX);
DECLARE_BITMAP(pmc_has_mode_specific_enables, X86_PMC_IDX_MAX);