Re: [PATCH net-next 9/9] netconsole: move netpoll_wait_carrier() as netcons_wait_carrier()

From: Gustavo Luiz Duarte

Date: Wed Jul 29 2026 - 10:22:13 EST


On Fri, Jul 24, 2026 at 4:05 PM Breno Leitao <leitao@xxxxxxxxxx> wrote:
>
> netpoll_wait_carrier() waits for the egress device carrier during
> netconsole setup. Its only caller, netcons_netpoll_setup(), already
> lives in netconsole. Move the function into drivers/net/netconsole.c,
> drop EXPORT_SYMBOL_GPL() and remove the prototype from <linux/netpoll.h>.
>
> Rename it to netcons_wait_carrier() for the netcons_ prefix. It now reads
> the timeout through netpoll_get_carrier_timeout(), since carrier_timeout
> stays in netpoll to keep the netpoll.carrier_timeout parameter.
>
> Signed-off-by: Breno Leitao <leitao@xxxxxxxxxx>

Reviewed-by: Gustavo Luiz Duarte <gustavold@xxxxxxxxx>