Re: [PATCH v3 00/21] md/md-llbitmap: support reshape for RAID10 and RAID5

From: yu kuai

Date: Wed Jul 29 2026 - 11:51:52 EST


Hi,

在 2026/7/28 16:49, Yu Kuai 写道:
> From: Yu Kuai <yukuai@xxxxxxx>
>
> Hi,
>
> This series adds llbitmap support for online reshape in RAID10 and RAID5.
>
> llbitmap has a different set of constraints from the existing bitmap code:
> there is one live bitmap instance, each bit state has richer semantics, and
> reshape can change the mapping from logical array ranges to bitmap ranges.
> The series therefore adds exact bitmap range mapping hooks, tracks old and
> new llbitmap geometry during reshape, remaps checkpointed bits as reshape
> progresses, and wires the reshape lifecycle into RAID10 and RAID5.
>
> The main rules are:
>
> 1. split bios at the reshape position before bitmap accounting, so one bio
> is never accounted with mixed old/new geometry;
> 2. do not skip reshape ranges from stale llbitmap state, because reshape
> progress is checkpointed by array metadata;
> 3. remap llbitmap bits when reshape progress is checkpointed;
> 4. reject llbitmap reshape if mddev->chunk_sectors shrinks, because the
> effective data range represented by existing bitmap bits can shrink.
>
> The first patch fixes RAID5 bitmap stripe rounding before the exact mapping
> hooks are added, so the later RAID5 helper split starts from correct
> sector_t division semantics. The rest of the series prepares generic bitmap
> and llbitmap infrastructure, wires RAID10, and then wires RAID5 with exact
> old/new stripe mapping.

There are some real problems reported by sashiko review, will send v4 set soon.

>
> Changes since v2:
> - Fix RAID5 bitmap stripe rounding for non-power-of-two stripe widths in
> patch 1.
> - Fix partial discard chunks being marked unwritten in patch 11.
> - Fix RAID5 writes past component size being skipped by llbitmap accounting
> in patch 11.
> - Fix stopped reshape reassembly losing target llbitmap geometry in patch 9.
> - Fix the page-cache-grow patch using target-geometry fields before they are
> introduced in patch 7.
>
> Changes since v1:
> - Add Reviewed-by tags from Su Yue.
> - Rename llbitmap_resize_chunks() to llbitmap_calculate_chunks().
> - Use an unsigned index in llbitmap_expand_pages() error cleanup.
> - Rebase on mdraid/md-7.2, including the mddev_bio_split_at_reshape_offset()
> declaration needed by the RAID5 build reported by kernel test robot.
>
> Yu Kuai (21):
> md/raid5: round bitmap stripes with sector division
> md: add exact bitmap mapping and reshape hooks
> md: skip bitmap accounting for empty write ranges
> md: add helper to split bios at reshape offset
> md/md-llbitmap: track bitmap sync_size explicitly
> md/md-llbitmap: allocate page controls independently
> md/md-llbitmap: grow the page cache in place for reshape
> md/md-llbitmap: track target reshape geometry fields
> md/md-llbitmap: finish reshape geometry
> md/md-llbitmap: refuse reshape while llbitmap still needs sync
> md/md-llbitmap: add reshape range mapping helpers
> md/md-llbitmap: don't skip reshape ranges from bitmap state
> md/md-llbitmap: remap checkpointed bits as reshape progresses
> md/md-llbitmap: clamp state-machine walks to tracked bits
> md/raid10: reject llbitmap reshape when md chunk shrinks
> md/raid10: wire llbitmap reshape lifecycle
> md/raid10: split reshape bios before bitmap accounting
> md/raid5: add exact old and new llbitmap mapping helpers
> md/raid5: reject llbitmap reshape when md chunk shrinks
> md/raid5: wire llbitmap reshape lifecycle
> md/raid5: split reshape bios before bitmap accounting
>
> drivers/md/md-bitmap.c | 8 +
> drivers/md/md-bitmap.h | 9 +
> drivers/md/md-llbitmap.c | 659 ++++++++++++++++++++++++++++++++++++---
> drivers/md/md.c | 64 +++-
> drivers/md/md.h | 8 +
> drivers/md/raid10.c | 49 +++
> drivers/md/raid5.c | 123 ++++++--
> 7 files changed, 842 insertions(+), 78 deletions(-)
>
>
> base-commit: 55b77337bdd088c77461588e5ec094421b89911b

--
Thanks,
Kuai