Re: [PATCH v5 2/2] thunderbolt: Add device links for Apple T2 NHI
From: Atharva Tiwari
Date: Wed Jul 29 2026 - 15:33:11 EST
> We should not be calling PCI functions anymore from the SW CM core. We have
> pci.c for that.
That is outside the scope of this patch, this should be another patch.
> I wonder if we can put this to pci.c, rename it to tb_pci_add_links()
> instead.
Same thing as before, its outside the scope of this patch.
> BTW, why you need to differentiate T2 vs. the rest of Apple x86? Don't this
> variable do?
Because the Patchset is specifically for T2 Macs.
> I'm not fan of __free() and the like so let's not use it here.
>
> Also you don't need to scan all the slots. Just look for the tunneled
> downstream ports based on their PCI IDs like we do already.
Could you please point me to the "like we do already" code you're referring to?
> This is unrelated change.
Its not. the patch specifically says T2 macs, and Titan ridge is only on T2 Macs
so we dont need to use has_apple_t2_chip for that.