Re: [PATCH v9 04/41] KVM: Rename memory attribute APIs to prepare for in-place gmem conversion
From: Xiaoyao Li
Date: Thu Jul 30 2026 - 04:31:37 EST
On 7/29/2026 8:35 AM, Ackerley Tng via B4 Relay wrote:
From: Sean Christopherson<seanjc@xxxxxxxxxx>
Rename memory attribute APIs to add a "vm_" in the name in anticipation of
moving PRIVATE tracking into guest_memfd, to allow in-place conversion
between SHARED and PRIVATE. At that point, there will effectively be two
(potential) sources of memory attributes: the VM and guest_memfd.
kvm_vm_set_mem_attributes() already has "vm" in the name to indicate that
it is a VM ioctl. Rename it to kvm_set_vm_mem_attributes() to show that it
is setting the VM's memory attributes. (Drop the VM-ioctl scoping since it
is a helper local to the file.) Update the accompanying trace function to
match.
No functional change intended.
Signed-off-by: Sean Christopherson<seanjc@xxxxxxxxxx>
Reviewed-by: Fuad Tabba<tabba@xxxxxxxxxx>
Tested-by: Shivank Garg<shivankg@xxxxxxx>
Signed-off-by: Ackerley Tng<ackerleytng@xxxxxxxxxx>
Reviewed-by: Xiaoyao Li <xiaoyao.li@xxxxxxxxx>