Re: [PATCH v2 06/17] mm/mm_init: factor out pfn_to_zone()
From: Mike Rapoport
Date: Thu Jul 30 2026 - 06:57:58 EST
> pfn_to_zone() in hugetlb_vmemmap.c duplicates the zone lookup logic in
> __init_deferred_page().
>
> Move it to mm_init.c, declare it in mm/internal.h, and reuse it from
> __init_deferred_page() and HugeTLB early vmemmap initialization instead
> of open-coding the zone walk there.
>
> Signed-off-by: Muchun Song <songmuchun@xxxxxxxxxxxxx>
With the commit message updated as you mentioned in your replies
Acked-by: Mike Rapoport (Microsoft) <rppt@xxxxxxxxxx>
--
Sincerely yours,
Mike.