Re: [RESEND PATCH v2] init/Kconfig: Move NUMA_BALANCING_DEFAULT_ENABLED next to NUMA_BALANCING
From: Chen, Yu C
Date: Thu Jul 30 2026 - 09:07:33 EST
On 7/29/2026 4:55 PM, Bing Huang wrote:
The NUMA_BALANCING_DEFAULT_ENABLED config option is semantically
related to NUMA_BALANCING. Move it directly after its parent option
so they are grouped together, improving readability.
As a side effect, the prompt for this option will now be indented
below that of NUMA_BALANCING in menuconfig, rendered as part of its
submenu.
No functional change beyond the visual grouping.
Signed-off-by: Bing Huang <huangbing@xxxxxxxxxx>
Reviewed-by: Julian Braha <julianbraha@xxxxxxxxx>
SCHED_CACHE seemed to break the tie between NUMA_BALANCING and
NUMA_BALANCING_DEFAULT_ENABLED, thanks for the adjustment.
Reviewed-by: Chen Yu <yu.c.chen@xxxxxxxxx>
thanks,
Chenyu