Re: [PATCH 2/2] soc: qcom: qcom_stats: Replace CLIENT_VOTES_OFFSET macro with sizeof()

From: Konrad Dybcio

Date: Thu Jul 30 2026 - 10:20:22 EST


On 7/30/26 10:46 AM, Maulik Shah wrote:
> CLIENT_VOTES_OFFSET (0x20) equals sizeof(struct sleep_stats), since
> appended_stats immediately follows sleep_stats in the memory layout.
> Replace the magic constant with sizeof(struct sleep_stats) to make
> the layout relationship self-documenting and drop the macro.
>
> No functional impact.
>
> Assisted-by: Claude:claude-sonnet-4-6
> Signed-off-by: Maulik Shah <maulik.shah@xxxxxxxxxxxxxxxx>
> ---

Reviewed-by: Konrad Dybcio <konrad.dybcio@xxxxxxxxxxxxxxxx>

Konrad