RE: [EXTERNAL] Re: [PATCH net-next v2] net: mana: Extend RX CQE coalescing up to 8 packets
From: Haiyang Zhang
Date: Wed Aug 05 2026 - 11:27:37 EST
> -----Original Message-----
> From: Breno Leitao <leitao@xxxxxxxxxx>
> Sent: Wednesday, August 5, 2026 7:48 AM
> To: Haiyang Zhang <haiyangz@xxxxxxxxxxxxxxxxxxx>
> Cc: linux-hyperv@xxxxxxxxxxxxxxx; netdev@xxxxxxxxxxxxxxx; KY Srinivasan
> <kys@xxxxxxxxxxxxx>; Haiyang Zhang <haiyangz@xxxxxxxxxxxxx>; Wei Liu
> <wei.liu@xxxxxxxxxx>; Dexuan Cui <DECUI@xxxxxxxxxxxxx>; Long Li
> <longli@xxxxxxxxxxxxx>; Andrew Lunn <andrew+netdev@xxxxxxx>; David S.
> Miller <davem@xxxxxxxxxxxxx>; Eric Dumazet <edumazet@xxxxxxxxxx>; Jakub
> Kicinski <kuba@xxxxxxxxxx>; Paolo Abeni <pabeni@xxxxxxxxxx>; Konstantin
> Taranov <kotaranov@xxxxxxxxxxxxx>; Simon Horman <horms@xxxxxxxxxx>; Erni
> Sri Satya Vennela <ernis@xxxxxxxxxxxxxxxxxxx>; Dipayaan Roy
> <dipayanroy@xxxxxxxxxxxxxxxxxxx>; Aditya Garg
> <gargaditya@xxxxxxxxxxxxxxxxxxx>; linux-kernel@xxxxxxxxxxxxxxx; linux-
> rdma@xxxxxxxxxxxxxxx; Paul Rosswurm <paulros@xxxxxxxxxxxxx>
> Subject: [EXTERNAL] Re: [PATCH net-next v2] net: mana: Extend RX CQE
> coalescing up to 8 packets
>
> On Fri, Jul 31, 2026 at 02:22:53PM -0700, Haiyang Zhang wrote:
> > From: Haiyang Zhang <haiyangz@xxxxxxxxxxxxx>
> >
> > To support up to 8 packets per CQE, update related CQE processing
> > code and structures.
> > Update ethtool handlers to set this feature.
> > Update per queue stat to show the coalesced CQE counters.
> > This feature is supported on NIC hardware showing the relevant
> > PF flag.
> >
> > Signed-off-by: Haiyang Zhang <haiyangz@xxxxxxxxxxxxx>
>
> Reviewed-by: Breno Leitao <leitao@xxxxxxxxxx>
>
>
> > +/* 8-pkt mode packs up to 2 packets per PPI entry */
> > +#define MANA_CQE_COAL_PKTS_8 8
>
> nit: The name encodes the value, so a future 16-packet mode would need
> a second macro with the same role. Wouldn't something like
> MANA_RXCOMP_MAX_COAL_PKTS age better?
The FW API uses mana_cqe_type like CQE_RX_COALESCED_8 for the CQE coalescing
x8, so I followed the same convention for the naming here.
When it supports 16pkt mode, we will decide if we rename this one or add a
new name based on the future API.
Thanks,
- Haiyang