Re: [PATCH bpf-next v11 02/10] bpf: Factor out check_map_mem_read helper in verifier

From: Eduard Zingerman

Date: Mon Aug 10 2026 - 17:39:25 EST


On Fri, 2026-08-07 at 00:31 +0800, Leon Hwang wrote:
> In the next commit, percpu_array map will add map_direct_value_addr
> support.
>
> IOW, it will add a map_type check in the iff condition of the
> bpf_map_direct_read() code block, which will reduce the code block
> readability.
>
> Hence, factor out check_map_mem_read helper to improve the readability,
> and the maintainability for the percpu_array map case.
>
> Signed-off-by: Leon Hwang <leon.hwang@xxxxxxxxx>
> ---

Acked-by: Eduard Zingerman <eddyz87@xxxxxxxxx>

...