Re: [PATCH v2 1/2] workqueue: Add missing EXPORT_SYMBOL_GPL for workqueue_set_min_active

From: Haakon Bugge

Date: Tue Aug 11 2026 - 12:02:37 EST




> On 10 Aug 2026, at 21:05, Bradley Morgan <include@xxxxxxxxx> wrote:
> On 10 August 2026 20:00:22 BST, Tejun Heo <tj@xxxxxxxxxx> wrote:
> >On Mon, Aug 10, 2026 at 06:34:30PM +0200, Håkon Bugge wrote:
> >> Adding a missing EXPORT_SYMBOL_GPL() in workqueue.c, as the
> >> workqueue_set_min_active() function is needed in the next commit.
> >
> >Can you just spell out who's gonna use it? I'm only cc'd on this one and
> >patch descs should be self-contained - it can reference future changes but
> >it should still be at least somewhat specific.
>
Hi Tejun,

Let me more specific in my v3 and also explicitly CC you on the commit
using workqueue_set_min_active().

> Mmm, shouldn't be complicated, perhaps
>
> Export workqueue_set_min_active() so that tests/loadable modules,
> e.g: test-ww_mutex can adjust workqueue concurrency levels to
> avoid deadlocks during cyclic test runs

Bradley, thanks for the suggestion. Will incorporate it in my v3.

Again, feel free to bikeshed.

As always ;-)


Thxs, Håkon