Re: [PATCH net v2] batman-adv: reject unrepresentable multicast TVLV offsets
From: Jakub Kicinski
Date: Tue Aug 11 2026 - 17:59:13 EST
On Mon, 10 Aug 2026 14:57:51 +0000 David Lee wrote:
> + long transport_offset = skb->data - skb->head + offset;
> +
> + if (unlikely(transport_offset !=
> + (typeof(skb->transport_header))transport_offset))
> + return false;
> +
> + if (unlikely(transport_offset ==
> + (typeof(skb->transport_header))~0U))
> + return false;
> +
> + skb->transport_header = transport_offset;
> + return true;
Find a better name for the variable instead of wrapping the lines.