Re: [RESEND PATCH v4 04/15] fs/resctrl: Introduce kernel mode (kmode) data structures

From: Moger, Babu

Date: Thu Aug 13 2026 - 18:36:06 EST


Hi Reinette,

On 8/13/2026 4:12 PM, Reinette Chatre wrote:
Hi Babu,

On 8/13/26 12:11 PM, Babu Moger wrote:
On 8/13/26 13:18, Reinette Chatre wrote:
On 8/13/26 10:12 AM, Babu Moger wrote:
On 8/13/26 10:55, Reinette Chatre wrote:

The "inherit" is the default property if it is not explicitly set. Right?

"property" is different from "kernel mode"

Each "kernel mode" can have zero or more properties.
"inherit" is the default "kernel mode", but it could have a better/more descriptive name.
For example, "inherit_from_user" or ...?

Or "user_inherit_kernel" ?

nit: to me this sounds as though user space inherits from kernel.

Also keep in mind that the filename is already "kernel_mode" so any text would
be interpreted within that context so repeating "kernel" may not be necessary.

May be "inherit_user". We can revisit again.



# cat info/kernel_mode
[inherit]
assign_global_enable_per_cpu:ctrl=inherit;mon=inherit;group=uninitialized


If the intention is to display all supported values for each
property, then we should do so consistently for all properties. For
example:

No. The intention is not to display all supported values for properties of the
different kernel modes. Just display which properties are supported and what value resctrl
would use if the user enables that mode without providing a value for a particular
property. There may be properties that could have values for which it will
be difficult to provide all supported values.

For example, if "kernel_mode" contains:
       # cat info/kernel_mode
       [inherit]
       assign_global_enable_per_cpu:ctrl=assign;mon=assign;group=//

Then user space knows that if they enable "assign_global_enable_per_cpu" kernel mode
without providing any properties then all kernel work will use the default resource
group's allocation and monitoring. If that is not what user space wants then they
can change the value of only the properties they need to change.

That sounds reasonable.

When the group is bound to the global mode,

# cat info/kernel_mode
  inherit
  [assign_global_enable_per_cpu:ctrl=assign;group=ctrl1//]

Looks good to me (while ignoring the "inherit" TBD naming change).


Thanks,
Babu