Re: [PATCH 1/2] dmaengine: use dma_chan_name() helper to get per-channel device name

From: Andy Shevchenko

Date: Fri Aug 14 2026 - 04:04:18 EST


On Wed, Aug 12, 2026 at 05:24:08PM -0400, Frank.Li@xxxxxxxxxxx wrote:

> Use the existing dma_chan_name() helper to obtain the per-channel device
> name instead of open-coding: dev_name(chan->dev->device) /
> dev_name(chan2dev())
>
> Simplify the code and improve consistency.
>
> No functional change intended.

...

> ret = devm_request_irq(dev, lchan->irq, loongson2_cmc_dma_chan_irq, IRQF_SHARED,
> - dev_name(chan2dev(lchan)), lchan);
> + dma_chan_name(&lchan->vchan.chan), lchan);

Depending on the amount of users (and I expect there is a number), I would
expect specific API for virt-dma case.

> if (ret)
> return ret;

--
With Best Regards,
Andy Shevchenko