[PATCH] ASoC: tegra: ADX: convert map to flexible array
From: Rosen Penev
Date: Fri Aug 14 2026 - 16:50:33 EST
Replace the pointer-based map allocation with a flexible array
member and use struct_size() for allocation. This simplifies
the code and avoid an extra allocation.
Assisted-by: opencode:big-pickle
Signed-off-by: Rosen Penev <rosenp@xxxxxxxxx>
---
sound/soc/tegra/tegra210_adx.c | 12 ++++--------
sound/soc/tegra/tegra210_adx.h | 2 +-
2 files changed, 5 insertions(+), 9 deletions(-)
diff --git a/sound/soc/tegra/tegra210_adx.c b/sound/soc/tegra/tegra210_adx.c
index 9175598b52a7..d607ba4233b6 100644
--- a/sound/soc/tegra/tegra210_adx.c
+++ b/sound/soc/tegra/tegra210_adx.c
@@ -677,11 +677,13 @@ static int tegra210_adx_platform_probe(struct platform_device *pdev)
void __iomem *regs;
int err, i;
- adx = devm_kzalloc(dev, sizeof(*adx), GFP_KERNEL);
+ soc_data = of_device_get_match_data(dev);
+ adx = devm_kzalloc(dev,
+ struct_size(adx, map, soc_data->ram_depth * TEGRA_ADX_SLOTS_PER_WORD),
+ GFP_KERNEL);
if (!adx)
return -ENOMEM;
- soc_data = of_device_get_match_data(dev);
adx->soc_data = soc_data;
dev_set_drvdata(dev, adx);
@@ -698,12 +700,6 @@ static int tegra210_adx_platform_probe(struct platform_device *pdev)
regcache_cache_only(adx->regmap, true);
- adx->map = devm_kcalloc(dev,
- soc_data->ram_depth * TEGRA_ADX_SLOTS_PER_WORD,
- sizeof(*adx->map), GFP_KERNEL);
- if (!adx->map)
- return -ENOMEM;
-
adx->byte_mask = devm_kcalloc(dev, soc_data->byte_mask_size,
sizeof(*adx->byte_mask), GFP_KERNEL);
if (!adx->byte_mask)
diff --git a/sound/soc/tegra/tegra210_adx.h b/sound/soc/tegra/tegra210_adx.h
index a6298c3dcca5..e5f1b44b2e76 100644
--- a/sound/soc/tegra/tegra210_adx.h
+++ b/sound/soc/tegra/tegra210_adx.h
@@ -92,8 +92,8 @@ struct tegra210_adx_soc_data {
struct tegra210_adx {
struct regmap *regmap;
unsigned int *byte_mask;
- u16 *map;
const struct tegra210_adx_soc_data *soc_data;
+ u16 map[];
};
#endif
--
2.55.0