Re: [PATCH v2 1/4] sysctl: Split data conversion and file position handling
From: Bradley Morgan
Date: Sat Aug 15 2026 - 12:06:31 EST
>Rename function to prov_vec (from do_proc_vec).
s/prov_vec/proc_vec/, the diff renames it to proc_vec.
Also the SIZE_MAX comment in proc_vec() only talks about the no
parsed element case, but after 3/4 a kmemdup failure leaves
left_nbyte unset too (it goes to out before buf_left_final gets
written). So the sentinel covers -ENOMEM as well, a line saying so
would help.
The split itself is fine, so with the typo fixed:
Reviewed-by: Bradley Morgan <include@xxxxxxxxx>
Thanks!