Re: [PATCH] mm/damon/core: introduce damon_set_target_pid()
From: SJ Park
Date: Mon Aug 17 2026 - 10:21:58 EST
On Mon, 17 Aug 2026 20:53:19 +0800 Enze Li <lienze@xxxxxxxxxx> wrote:
> The logic that finds the struct pid for a given pid number and assigns
> it to a damon_target is duplicated in multiple places. Including
> damon_sysfs_add_target() of mm/damon/sysfs.c and the start functions
> of the two sample modules, samples/damon/wsse.c and
> samples/damon/prcl.c. Add a function that does the work, and replace
> the duplicated code in the places with calls to the function.
Looks good to me, thank you!
>
> Signed-off-by: Enze Li <lienze@xxxxxxxxxx>
Reviewed-by: SJ Park <sj@xxxxxxxxxx>
This patch is applied to damon/next [1] tree. If this patch is not added to
mm.git in short term, I will ask mm.git maintainer (Andrew Morton) to pick
this. Note that we are in the middle of the merge window. The action would be
made only after the end of the window. So, no action from your side is needed
for now. If it seems I also forgot doing that or you cannot wait for my
action, please feel free to directly ask that to Andrew.
[1] https://origin.kernel.org/doc/html/latest/mm/damon/maintainer-profile.html#scm-trees
Thanks,
SJ
[...]