linux-next: manual merge of the driver-core tree with the pm tree
From: Mark Brown
Date: Mon Aug 17 2026 - 11:58:22 EST
Hi all,
Today's linux-next merge of the driver-core tree got a conflict in:
include/acpi/acpi_bus.h
between commit:
72530e1f72b05 ("ACPI: bus: Introduce acpi_bus_get_primary_device()")
from the pm tree and commit:
2c5d17cdc4e97 ("rust: driver: remove open-coded matching logic")
from the driver-core tree.
I fixed it up (see below) and can carry the fix as necessary. This
is now fixed as far as linux-next is concerned, but any non trivial
conflicts should be mentioned to your upstream maintainer when your tree
is submitted for merging. You may also want to consider cooperating
with the maintainer of the conflicting tree to minimise any particularly
complex conflicts.
diff --cc include/acpi/acpi_bus.h
index eaf13f6ac2d3a,7e57f9698f7ce..0000000000000
--- a/include/acpi/acpi_bus.h
+++ b/include/acpi/acpi_bus.h
@@@ -953,18 -996,6 +949,11 @@@ int acpi_scan_add_dep(acpi_handle handl
u32 arch_acpi_add_auto_dep(acpi_handle handle);
#else /* CONFIG_ACPI */
+static inline struct device *acpi_bus_get_primary_device(struct acpi_device *adev)
+{
+ return NULL;
+}
+
- static inline bool acpi_of_match_device(const struct acpi_device *adev,
- const struct of_device_id *of_match_table,
- const struct of_device_id **of_id)
- {
- return false;
- }
-
static inline int register_acpi_bus_type(void *bus) { return 0; }
static inline int unregister_acpi_bus_type(void *bus) { return 0; }
Attachment:
signature.asc
Description: PGP signature