Re: [PATCH net-next v2 1/2] dt-bindings: net: dsa: realtek: add RTL8365MB power supplies

From: Krzysztof Kozlowski

Date: Tue Aug 18 2026 - 03:57:23 EST


On Tue, Aug 11, 2026 at 01:39:00PM +0200, Oleksij Rempel wrote:
> Document the RTL8365MB power rails as optional supplies. They are optional
> because the rails are often always-on; some designs break them out for
> granular hwmon monitoring and regulator control.
>
> They are scoped to realtek,rtl8365mb: different Realtek switch families use
> different power-rail naming schemes, so these rails do not apply to other
> families such as realtek,rtl8366rb (VDDA/VDD_CORE/VDDIO/...).
>
> Signed-off-by: Oleksij Rempel <o.rempel@xxxxxxxxxxxxxx>
> ---
> .../devicetree/bindings/net/dsa/realtek.yaml | 25 +++++++++++++++++++
> 1 file changed, 25 insertions(+)
>
> diff --git a/Documentation/devicetree/bindings/net/dsa/realtek.yaml b/Documentation/devicetree/bindings/net/dsa/realtek.yaml
> index 473facd87a62..98ea6072bd96 100644
> --- a/Documentation/devicetree/bindings/net/dsa/realtek.yaml
> +++ b/Documentation/devicetree/bindings/net/dsa/realtek.yaml
> @@ -8,6 +8,30 @@ title: Realtek switches for unmanaged switches
>
> allOf:
> - $ref: dsa.yaml#/$defs/ethernet-ports
> + - if:
> + properties:
> + compatible:
> + contains:
> + const: realtek,rtl8365mb
> + then:
> + properties:
> + avddh-supply:
> + description: AVDDH high-voltage analog supply.

Properties cannot be defined in if: block. Only in top-level. You only
customize them, see also writing bindings and writing schema.

Best regards,
Krzysztof