Re: [PATCH v4 1/4] dmaengine: add dma_device_get() helper
From: Logan Gunthorpe
Date: Tue Aug 18 2026 - 11:49:03 EST
On 2026-08-17 21:43, Shivank Garg wrote:
> Add dma_device_get() helper to match dma_device_put() to make code
> symmetric. It wraps open-coded kref_get_unless_zero() and asserts that
> dma_list_mutex is held, matching its put counterpart.
>
> No functional change intended.
>
> Suggested-by: Frank Li <Frank.Li@xxxxxxx>
> Signed-off-by: Shivank Garg <shivankg@xxxxxxx>
Makes sense to me:
Reviewed-by: Logan Gunthorpe <logang@xxxxxxxxxxxx>