Re: [PATCH 1/7] media: verisilicon: Fix the cleanup when a codec ->run() fails

From: Nicolas Dufresne

Date: Wed Aug 19 2026 - 11:07:11 EST


Hi Sascha,

Le mercredi 19 août 2026 à 12:37 +0200, Sascha Hauer a écrit :
>   ret = start_prepare_run(ctx, &decode_params);
>   if (ret) {
> - hantro_end_prepare_run(ctx);
> + hantro_end_prepare_run(ctx, ret);

Since its already in an if (ret) branch, and for code readability, can you use
hantro_abort_prepare_run(ctx) instead and leave all other sucessful calls as-is.

Nicolas

Attachment: signature.asc
Description: This is a digitally signed message part