[PATCH v1 3/4] powercap: dtpm: Rename Rockchip virtual node descriptor

From: Daniel Lezcano

Date: Wed Aug 19 2026 - 12:57:09 EST


The virtual DTPM node descriptor is named after the RK3399 even though
it does not contain any SoC-specific information.

Rename it to rockchip_virtual so it can be reused by other Rockchip SoC
hierarchies.

No functional change intended.

Signed-off-by: Daniel Lezcano <daniel.lezcano@xxxxxxxxxxxxxxxx>
---
drivers/soc/rockchip/dtpm.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/drivers/soc/rockchip/dtpm.c b/drivers/soc/rockchip/dtpm.c
index 451417ae5715..5f7f238a15fe 100644
--- a/drivers/soc/rockchip/dtpm.c
+++ b/drivers/soc/rockchip/dtpm.c
@@ -11,7 +11,7 @@
#include <linux/of.h>
#include <linux/platform_device.h>

-static struct dtpm_node rk3399_virtual = {
+static struct dtpm_node rockchip_virtual = {
.type = DTPM_NODE_VIRTUAL,
};

@@ -33,12 +33,12 @@ static struct dtpm_node rk3399_gpu = {
static struct powercap_node __initdata rk3399_nodes[] = {
[0] = {
.name = "rk3399",
- .data = &rk3399_virtual,
+ .data = &rockchip_virtual,
},
[1] = {
.name = "package",
.parent = &rk3399_nodes[0],
- .data = &rk3399_virtual,
+ .data = &rockchip_virtual,
},
[2] = {
.name = "cpu0-cpufreq",
--
2.43.0