Re: [PATCH v4 15/15] rtc: rzn1: Add support for Renesas RZ/T2H and RZ/N2H SoCs
From: Lad, Prabhakar
Date: Fri Aug 21 2026 - 03:51:25 EST
Hi Wolfram,
On Wed, Aug 19, 2026 at 11:41 AM Prabhakar <prabhakar.csengg@xxxxxxxxx> wrote:
>
> From: Lad Prabhakar <prabhakar.mahadev-lad.rj@xxxxxxxxxxxxxx>
>
> Add support for the RTC block found on the Renesas RZ/T2H (R9A09G077)
> and RZ/N2H (R9A09G087) SoCs.
>
> These SoCs integrate a closely related variant of the RZ/N1 RTC IP, but
> do not implement the RTCA0SUBU register. Use variant-specific match data
> to disable SUBU support for these SoCs.
>
> Signed-off-by: Lad Prabhakar <prabhakar.mahadev-lad.rj@xxxxxxxxxxxxxx>
> ---
> v3->v4:
> - Dropped RB tag from Wolfram.
> - Added OF rzt2h_data
> - Updated commit message.
>
> v2->v3:
> - No changes.
>
> v1->v2:
> - Updated commit message to drop reference about RTCA0TCR register.
> - Added Reviewed-by tag.
> ---
> drivers/rtc/rtc-rzn1.c | 5 +++++
> 1 file changed, 5 insertions(+)
>
> diff --git a/drivers/rtc/rtc-rzn1.c b/drivers/rtc/rtc-rzn1.c
> index 6097563c5f13..32f6464fe7d2 100644
> --- a/drivers/rtc/rtc-rzn1.c
> +++ b/drivers/rtc/rtc-rzn1.c
> @@ -508,11 +508,16 @@ static int rzn1_rtc_probe(struct platform_device *pdev)
> return devm_rtc_register_device(rtc->rtcdev);
> }
>
> +static const struct rzn1_rtc_data rzt2h_data = {
For consistency I'll rename this to rzn1_rtc_rzt2h_data to align with
rzn1_rtc_rzn1_data.
Cheers,
Prabhakar
> + .has_subu = false,
> +};
> +
> static const struct rzn1_rtc_data rzn1_data = {
> .has_subu = true,
> };
>
> static const struct of_device_id rzn1_rtc_of_match[] = {
> + { .compatible = "renesas,r9a09g077-rtc", .data = &rzt2h_data },
> { .compatible = "renesas,rzn1-rtc", .data = &rzn1_data },
> { /* sentinel */ }
> };
> --
> 2.43.0
>