Re: [PATCH v4 2/7] iommu/amd: KVM: SVM: Rename ga_log_intr to wakeup_intr in IOMMU interface

From: Vasant Hegde

Date: Fri Aug 21 2026 - 11:58:36 EST




On 8/21/2026 11:26 AM, Sairaj Kodilkar wrote:
> When AVIC is enabled, device interrupts are posted into the guest virtual
> APIC backing page regardless of vCPU running state. When the vCPU is not
> running, KVM may additionally need the IOMMU to notify the host so the
> vCPU can be woken, historically via the GA log mechanism.
>
> The existing ga_log_intr name is tied to one specific hardware mechanism.
> Guest APIC Physical Processor Interrupt (GAPPI) provides an alternative
> host-notification path when the vCPU is not running, i.e., IRTE[IsRun] = 0.
> The KVM-side intent is the same in both cases: request host wakeup
> notification while the vCPU is blocked.
>
> Rename ga_log_intr to wakeup_intr in the IOMMU API to describe KVM's
> intent rather than a single hardware knob. The IOMMU driver still maps
> wakeup_intr to IRTE[GALogIntr] in this patch; GAPPI support is added in
> following patches.
>
> Similarly rename the synthetic AVIC physical ID table shadow bit from
> AVIC_PHYSICAL_ID_ENTRY_GA_LOG_INTR to AVIC_PHYSICAL_ID_ENTRY_WAKEUP_INTR.
>
> No functional change is intended.
>
> Signed-off-by: Sairaj Kodilkar <sarunkod@xxxxxxx>

Reviewed-by: Vasant Hegde <vasant.hegde@xxxxxxx>

-Vasant