Re: [PATCH v2 3/4] hwmon: (ina2xx) Replace masks with enum in alert functions
From: Guenter Roeck
Date: Fri Aug 21 2026 - 15:47:57 EST
On Thu, Aug 20, 2026 at 06:09:23AM -0700, Jared Kangas wrote:
> Instead of passing an explicit mask to alert/limit functions like
> ina226_alert_read(), introduce an enum ina2xx_alert_type that can be
> converted to a mask internally. This semantically separates current from
> shunt voltage in helpers that use function masks, which previously saw
> the same mask for the two functions.
>
> Signed-off-by: Jared Kangas <jkangas@xxxxxxxxxx>
Applied.
Thanks,
Guenter