Re: [PATCH] mtd: rawnand: ndfc: use devm_platform_ioremap_resource

From: Markus Elfring

Date: Sun Aug 23 2026 - 04:49:48 EST


> Replace the open-coded of_iomap()/iounmap() with the managed
> devm_platform_ioremap_resource() helper. This fixes a mapping leak on
> probe failure and on driver remove (the old code never called
> iounmap()) and simplifies the error path by dropping the manual
> cleanup in ndfc_probe().

> ---
> drivers/mtd/nand/raw/ndfc.c | 19 +++++++------------


How do you think about to add any tags (like “Fixes” and “Cc”) accordingly?

See also:
* https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/Documentation/process/submitting-patches.rst?h=v7.2#n145
* https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/Documentation/process/stable-kernel-rules.rst?h=v7.2#n34


Would it be helpful to append parentheses also to a function name
in the summary phrase?

Regards,
Markus