Re: [RFC PATCH 03/57] mm/collapse: add collapse.h for the shared collapse state

From: Kiryl Shutsemau

Date: Mon Aug 24 2026 - 08:37:09 EST


On Mon, Aug 24, 2026 at 02:28:39PM +0200, David Hildenbrand (Arm) wrote:
> On 8/24/26 14:10, Kiryl Shutsemau wrote:
> > On Mon, Aug 24, 2026 at 01:47:54PM +0200, David Hildenbrand (Arm) wrote:
> >> On 8/20/26 13:11, Kiryl Shutsemau wrote:
> >>>
> >>> I went for a clean collapse.c on purpose: the engine is new code, and a
> >>> new file keeps it readable while both mechanisms are in the tree, with 28
> >>> as a plain delete from khugepaged.c.
> >>>
> >>> Your shape is less churn, though, and it keeps blame: 29-35 move about
> >>> 1700 lines as add-and-delete today, and most of that would stay put, with
> >>> only the daemon -- mm_slot, the scan loop, sysfs -- extracted into a new
> >>> khugepaged.c.
> >>>
> >>> If you prefer it that way, I can give it a try for v2.
> >>>
> >>> The rename has to open the series, so it will collide with anything in
> >>> flight that touches khugepaged.c.
> >>>
> >>
> >> Kiryl, I have to ask, are you using AI to write your replies?
> >
> > Yes. I use it check my claims and fix my grammar.
> >
> > Why?
> >
>
> It doesn't read the way you would usually write. In a bad way.
>
> E.g., "Your shape", "has to open the series"
>
> Consider telling the LLM to not change your writing style and focus only on
> fixing grammar.

Right. Asking for rewrite with proper grammar was a bad move on my part.

--
Kiryl Shutsemau / Kirill A. Shutemov