RE: [PATCH rtw-next v6 1/3] wifi: rtw88: rtw8822c: Use bitfield macros for DAC IQ sampling

From: Ping-Ke Shih

Date: Tue Aug 25 2026 - 03:42:58 EST


Arsenii Pashchenko <ulijg308@xxxxxxxxx> wrote:
> Define proper GENMASK constants for the In-phase (I) and Quadrature
> (Q) components of the DAC IQ data register in the header file.
> Replace manual bit shifting, masking, and rtw_read32_mask() with
> standard rtw_read32() and the FIELD_GET() macro to improve code
> readability.
>
> Signed-off-by: Arsenii Pashchenko <ulijg308@xxxxxxxxx>

Acked-by: Ping-Ke Shih <pkshih@xxxxxxxxxxx>