Re: [PATCH] spi: qcom-geni: rename setup_fifo_params() to setup_spi_params() and make it void
From: Abel Vesa
Date: Tue Aug 25 2026 - 06:13:52 EST
On 26-08-25 14:01:10, Mukesh Savaliya wrote:
>
>
> On 8/24/2026 3:43 PM, Viken Dadhaniya wrote:
> > The function always returned 0 and had no error paths, so change its
> > return type to void. Drop the now-dead ret variable and error check
> > in spi_geni_prepare_message().
> >
> > setup_fifo_params() is called for both GENI_SE_FIFO and GENI_SE_DMA
> > modes, so the "fifo" in the name is misleading. Rename it to
> > setup_spi_params() to better reflect its purpose of configuring SPI
> > mode parameters (CS, CPHA, CPOL, loopback, LSB-first).
> >
> > No functional change.
> >
> > Signed-off-by: Viken Dadhaniya <viken.dadhaniya@xxxxxxxxxxxxxxxx>
> > ---Reviewed-by: Mukesh Kumar Savaliya <mukesh.savaliya@xxxxxxxxxxxxxxxx>
FYI, there is a chance these might not be picked up by b4, when
applying.
Make sure when you reply with tags, they are actually part of the new
message.