Re: [PATCH v3 1/5] iommu/amd: Refactor device probe and capability initialization

From: Pranjal Shrivastava

Date: Tue Aug 25 2026 - 06:27:44 EST


On Tue, Aug 25, 2026 at 12:29:35PM +0530, Vasant Hegde wrote:
>
>
> On 8/24/2026 5:53 PM, Pranjal Shrivastava wrote:
> > Restructure the device probe path to improve readability and prepare for
> > cleaner error handling. Refactor check_device() into iommu_lookup_device
> > to explicitly validate and return the amd_iommu ptr & devid. Refactor
> > iommu_init_device() to return the allocated dev_data. Consolidate all
> > PCI cap inits (MSI domains, PASID, ATS) into a new helper:
> > iommu_init_device_caps().
> >
> > Suggested-by: Vasant Hegde <vasant.hegde@xxxxxxx>
> > Signed-off-by: Pranjal Shrivastava <praan@xxxxxxxxxx>
>
> One minor nit. Otherwise patch looks good.
>
> Reviewed-by: Vasant Hegde <vasant.hegde@xxxxxxx>
>
>
>
> > ---
> > drivers/iommu/amd/iommu.c | 117 +++++++++++++++++++-------------------
> > 1 file changed, 60 insertions(+), 57 deletions(-)
> >
> > diff --git a/drivers/iommu/amd/iommu.c b/drivers/iommu/amd/iommu.c
> > index 4c31294fabc5..e1f9fbb63837 100644
> > --- a/drivers/iommu/amd/iommu.c
> > +++ b/drivers/iommu/amd/iommu.c
> > @@ -675,7 +675,8 @@ static void pdev_disable_caps(struct pci_dev *pdev)
>
>
> .../...
>
> > static struct iommu_device *amd_iommu_probe_device(struct device *dev)
> > {
> > struct iommu_device *iommu_dev;
> > struct amd_iommu *iommu;
> > struct iommu_dev_data *dev_data;
> > int ret;
> > + u16 devid;
> >
> > - if (!check_device(dev))
> > - return ERR_PTR(-ENODEV);
> > -
> > - iommu = rlookup_amd_iommu(dev);
> > - if (!iommu)
> > - return ERR_PTR(-ENODEV);
> > -
> > - /* Not registered yet? */
> > - if (!iommu->iommu.ops)
> > + if (!iommu_lookup_device(dev, &iommu, &devid))
> > return ERR_PTR(-ENODEV);
> >
> > if (dev_iommu_priv_get(dev))
> > return &iommu->iommu;
> >
> > - ret = iommu_init_device(iommu, dev);
> > - if (ret) {
> > + dev_data = iommu_init_device(iommu, dev, devid);
> > + if (IS_ERR(dev_data)) {
> > + ret = PTR_ERR(dev_data);
>
> Instead of this, you can change below iommu_Dev assignment directly.

Ack, I'll change iommu_dev assignment directly.

>
> -Vasant
>
> > dev_err(dev, "Failed to initialize - trying to proceed anyway\n");
> > iommu_dev = ERR_PTR(ret);
> > iommu_ignore_device(iommu, dev);
> > goto out_err;
> > }
> >

Thanks,
Praan