Re: [PATCH v2 1/3] mm/memory.c: rename walk_to_pmd() to populate_to_pmd()
From: David Hildenbrand (Arm)
Date: Tue Aug 25 2026 - 06:43:56 EST
On 8/5/26 16:42, Avi Weiss wrote:
> This helper allocates any missing page-table levels (it doesn't just
> 'walk'. Rename for clarity.
I don't think that's any clearer. The point it that population is just a
side-effect of performing the walk.
The main job of this function is to return a pmd_t pointer.
--
Cheers,
David